相信自己是对的,朋友多多才是走向成功的开始……

自己的事自己办!

统计

积分与排名

空间

网址

自己

最新评论

帧中继概述

3.1.1         帧中继相关术语

l         PVC(永久虚电路)  传输帧的逻辑端到端电路,PVC的终点是用DLCI来寻址。

l         DLCI(数据链路连接标识符)  16-1007的逻辑数字,标识CPE和帧中继交换机之间的PVC,只在本地有效。

l         LMI(本地管理接口)  router and frame switch 之间使用的信令标准,交换机使用LMI确定已定义的DLCI及其状态。支持10s间隔的keepalive机制。Cisco支持三种LMI:

※       CISCO:Cisco、Digital和Northern Telecom定义,自动协商失败后默认的LMI类型,状态信息通过DLCI 0传送。

※       ANSI:ANSI标准T1.617定义,最常用的LMI类型,通过DLCI1023传送。

※       Q933A定义为ITU-T Q.933的LMI类型,状态信息通过DLCI 0传送。

l         NNI网络网络接口)  2台交换机间通信标准,帧中继和ATM均使用NNI,ATM称为网络节点接口(Network Node Interface)。

l         本地访问速率  与帧中继服务提供者相连链路的时钟速率或称接口速率。可以工作在T1、T3或者HSSI下。

图3-1为常用的帧中继网络示意图

下面术语称为数据速率度量值服务商使用这些来规定服务级别,这些术语还用于帧中继流量整形:

l       Bc(承诺突发量)  以CIR为基础的允许接收和发送的bit number

l       CIR(承诺信息速率)  PVC允许的最大的数据速率,超过时置为可丢弃位(DE)。单位bit/s。

l       Bc(过量突发)  达到了承诺突发值之后可发送的超出bit number。

l       MaxR(最大速率)  单位bit/s,计算公式:MaxR=CIR×((Bc+Be)/Bc)。

图3-2显示各种速率间的关系。

3.1.2         技术概览

帧中继特点:

l        通过统计多路复用技术全多个逻辑电路功能在一个物理电路上实现。

l        不需要链路具备专门的端到端的电路,降低成本。

l        统计多路复用技术通过减少对router串中和CSU/DSU的使用需求,增加了网络的可扩展性。

l        可扩展网络设计:

※       三层结构:核心层、分布层和访问层。

※       全连接、部分连接和混合连接。

※       增加了协议广播和性能控制。

 

帧中继使用的是面向连接的数据流,依靠上层网络协议完成错误检测和纠正。

帧中继是CCIT和ANSI的标准,替换X.25协议。

下面标准描述了帧中继:

l        ANSI T1.606:“帧中继传输服务的框架结构和服务描述”(1991)

l        ANSI T1.617:“帧中继传输服务的信令定义”(1991)

l        ANSI T1.618:“帧中继传输服务的核心部分”(1991)

l        ITU Q9.33 and Q.922:用户控制

l        RFC 1490:帧中继封装定义

www.frforum.com上有帧中继的实例和其他相关资料。

3.1.3         帧中继LMI操作

帧中继链路在Cisco router(DTE)上激活并开始工作时,首先连续向router发3个LMI消息(ANSI、ITU和CISCO。Router在DLCI 1023上监听CISCO消息,DLCI 0上监听ANSI和ITU消息,帧中继响应后router设定接口的LMI类型以与接收到LMI类型相匹配。收到多个LMI时使用最后一个类型,Cisco称这种方式为LMI autosense。

然后Router每10s发一次LMI状态信息,即LMI keepalive。Router工作在图3-3所示的方式中。

图3-3 帧中继LMI的工作模式

1.         每经第6个LMI 状态请求,DTE发一个完整的状态请求。见例3-1显示LMI交换的信息:

例3-1 debug frame lmi所显示的信息

02:01:54: Serial1/0(out): StEnq, myseq 216, yourseen 215, DTE up

02:01:54: datagramstart = 0x5800AD4, datagramsize = 14

02:01:54: FR encap = 0x00010308

02:01:54: 00 75 95 01 01 00 03 02 D8 D7

02:01:54:

02:01:54: Serial1/0(in): Status, myseq 216

02:01:54: RT IE 1, length 1, type 0

02:01:54: KA IE 3, length 2, yourseq 216, myseq 216

02:01:54: PVC IE 0x7 , length 0x3 , dlci 502, status 0x2

02:01:54: PVC IE 0x7 , length 0x3 , dlci 503, status 0x2

02:01:54: PVC IE 0x7 , length 0x3 , dlci 504, status 0x2

02:02:04: Serial1/0(out): StEnq, myseq 217, yourseen 216, DTE up

02:02:04: datagramstart = 0x58014D4, datagramsize = 14

02:02:04: FR encap = 0x00010308

02:02:04: 00 75 95 01 01 01 03 02 D9 D8

02:02:04:

02:02:04: Serial1/0(in): Status, myseq 217

02:02:04: RT IE 1, length 1, type 1

02:02:04: KA IE 3, length 2, yourseq 217, myseq 217

02:02:14: Serial1/0(out): StEnq, myseq 218, yourseen 217, DTE up

02:02:14: datagramstart = 0x5801B14, datagramsize = 14

02:02:14: FR encap = 0x00010308

02:02:14: 00 75 95 01 01 01 03 02 DA D9

02:02:14:

02:02:14: Serial1/0(in): Status, myseq 218

02:02:14: RT IE 1, length 1, type 1

02:02:14: KA IE 3, length 2, yourseq 218, myseq 218

02:02:24: Serial1/0(out): StEnq, myseq 219, yourseen 218, DTE up

02:02:24: datagramstart = 0x5AFAEF4, datagramsize = 14

02:02:24: FR encap = 0x00010308

02:02:24: 00 75 95 01 01 01 03 02 DB DA

02:02:24:

02:02:24: Serial1/0(in): Status, myseq 219

02:02:24: RT IE 1, length 1, type 1

02:02:24: KA IE 3, length 2, yourseq 219, myseq 219

02:02:34: Serial1/0(out): StEnq, myseq 220, yourseen 219, DTE up

02:02:34: datagramstart = 0x5801894, datagramsize = 14

02:02:34: FR encap = 0x00010308

02:02:34: 00 75 95 01 01 01 03 02 DC DB

02:02:34:

02:02:34: Serial1/0(in): Status, myseq 220

02:02:34: RT IE 1, length 1, type 1

02:02:34: KA IE 3, length 2, yourseq 220, myseq 220

02:02:44: Serial1/0(out): StEnq, myseq 221, yourseen 220, DTE up

02:02:44: datagramstart = 0x5AFB034, datagramsize = 14

02:02:44: FR encap = 0x00010308

02:02:44: 00 75 95 01 01 01 03 02 DD DC

02:02:44:

02:02:44: Serial1/0(in): Status, myseq 221

02:02:44: RT IE 1, length 1, type 1

02:02:44: KA IE 3, length 2, yourseq 221, myseq 221

02:02:54: Serial1/0(out): StEnq, myseq 222, yourseen 221, DTE up

02:02:54: datagramstart = 0x5AFB3F4, datagramsize = 14

02:02:54: FR encap = 0x00010308

02:02:54: 00 75 95 01 01 00 03 02 DE DD

02:02:54:

02:02:54: Serial1/0(in): Status, myseq 222

02:02:54: RT IE 1, length 1, type 0

02:02:54: KA IE 3, length 2, yourseq 222, myseq 222

02:02:54: PVC IE 0x7 , length 0x3 , dlci 502, status 0x2

02:02:54: PVC IE 0x7 , length 0x3 , dlci 503, status 0x2

02:02:54: PVC IE 0x7 , length 0x3 , dlci 504, status 0x2

02:03:04: Serial1/0(out): StEnq, myseq 223, yourseen 222, DTE up

02:03:04: datagramstart = 0x5AFBB74, datagramsize = 14

02:03:04: FR encap = 0x00010308

02:03:04: 00 75 95 01 01 01 03 02 DF DE

02:03:04:

02:03:04: Serial1/0(in): Status, myseq 223

02:03:04: RT IE 1, length 1, type 1

02:03:04: KA IE 3, length 2, yourseq 223, myseq 223

 

2.         帧中继交换机接收到信号后,发送完整响应消息,包含所有DLCI列表。

3.         工作中的DLCI,router根据接口配置的第3层网络协议发送一个逆向ARP请求。如果不支持RARP请求,则需要使用frmae-relay map,后面再讲。

4.         根据收到的RARP信息里所包含的每条DLCI在基帧中继映射表中建立一个映射项。包括本地DLCI和发出请求的远端router的网络层地址信息,PVC状态信息,可以使用show frame-relay pvc命令显示,三种状态:Router

※       ACTIVE  表明PVC工作正常。

※       INACTIVE   本地连接正常,远端router到帧中继交换机没有工作。

※       DELETED  没有收到LMI or 物理层连接未建立。

5.         每10s交换一次keepalive,每60s or 每到第6次交换时,发送一个完整LMI状态请求,如果连续3次完整状态请求没有收到LMI信号,就表明链路断开了。router

3.2</Script>>         帧中继的配置

第1步  在接口或子接口进行帧中继封装

Router(config-if)#encapsulaion frame-relay [ cisco | ietf ]

Cisco是默认封装,符合RFC1490 or cisco设备时使用。第三方时用ietf。

 

第2步  设置LMI类型

IOS 11.2 or later的router支持LMI auto autosense。手工配置使用下面命令:

Router(config-if)#frame-relay lmi-type [ ansi | cisco | q933i ]

LMI默认类型是cisco。

 

第3步  配置静态or动态地址映射

根据远端设备是否支持RARP选用frame-relay map or frame-relay interface-dlci命令。

两种子接口类型: 

※       Point-to-point

使用如下命令:

Router(config-if)#frame-relay interface-dlci dlci_number

※       Point-to-multipoint

需要使用静态寻址方式,主要是因为路由的问题决定。使用下面命令配置:

Router(config-if)#frame-relay map protocol [ ip | dec | appletalk | xns | ipx | vines | clns | bridge | llc2 | dlsw ] next_hop_address [ broadcast ] [ ietf | cisco ]

Frame-relay map是在本地DLCI和下一跳建立地址映射。Broadcast用来转发广播,建议无论何时都采用。

表3-1 列出不同接口逆向ARP地址映射的一些用法

 表3-1 推荐的RARP和对应的地址映射  

标准接口

Point-to-multipoint

Point-to-point

连接到不支持RARP的设备

每个协议加入网络地址      

每个协议加入网络地址。使用frame-relay map

每个协议加入网络地址,使用 

frame-relay interface-dlci 

每个协议加入网络地址。使用frame-relay map

静态or 动态寻址

静态寻址

动态寻址

静态寻址

 第4步  相关协议问题

在帧中继上配置路由需要注意的问题。如:ospf时需要使用neighbor声明or 改变网络类型。

距离矢量路由协议or eigrp 的多点网络有水平分割问题,表3-2列出常见问题。

表3-2 帧中继网络常见问题

Protocol                  
Point-to-multipoint
Point-to-point
OSPF
必须使用neighbor声明or接口上使用ip ospf network type命令,使用优先级1设置DR路由器,该router有到all neihgebor的PVC。
必须使用neighbor声明,或者在接口上使用ip ospf network type broadcast命令。
EIGRP
关闭水平分割,加入bandwidth命令
加入bandwidth命令
IGRP
关闭水平分割,加入bandwidth命令
加入bandwidth命令
RIP
关闭水平分割
BGP
桥接
设置到router的根桥,该根桥具到all子桥的PVC
设置到router的根桥,该根桥具到all子桥的PVC

注:在rip or igrp网络中使用no ip split-horizon关闭水平分割。

在EIGRP网络中使用no ip split-horizon eigrp autonomous_system命令关闭。

在point-to-point接口配置中无需关闭。

3.2.1         实例:配置混合型帧中继网络

图3-4是一个混合型的帧中继网络,在本例中要配置router A、B、C之间的point-to-multipoint网络

还要配置一个point-to-point网络。Route protocol use igrp。

图3-4 帧中混合型网络

先配置R5开始,先配置㥈中继封装,然后配置两种类型子接口。路由器配置见例3-1 所示。

例3-2 封装的设置和子接口类型定义

R5(config)#int s1/0

R5(config-if)#encapsulation frame-relay

R5(config)#int s1/0.1 multipoint          <-配置点到多点子接口

R5(config-subif)#ip add 172.16.1.5 255.255.255.0

R5(config-subif)#frame-relay map ip 172.16.1.2 502 broadcast <-配置静态寻址

R5(config-subif)#frame-relay map ip 172.16.1.3 503 broadcast

R5(config-subif)#exit

R5(config)#int s1/0.2 point-to-point  <-配置点到点子接口

R5(config-subif)#ip add 172.16.16.5 255.255.255.0

R5(config-subif)#frame-relay interface-dlci 504   <-配置动态寻址

 

配置R2路由器上的点对多点接口,此路由器上不需要配置子接口。如例3-2所示:

例3-3 R2路由器点对多点配置

R2(config)#int s1/0

R2(config-if)#ip add 172.16.1.2 255.255.255.0

R2(config-if)#encapsulation frame-felay

R2(config-if)#frame-relay map ip 172.16.1.5 205 broadcast

R2(config-if)#frame-relay map ip 172.16.1.3 205 broadcast

R2(config-if)#

 

配置R4路由器上的点到点接口,如例3-3所示:

例3-4 R4路由器点对点配置

R4(config)#int s1/0

R4(config-if)#encapsulation frame-relay

R4(config-if)#ip add 172.16.16.4 255.255.255.0

R4(config-if)#frame

R4(config-if)#frame-relay interface-dlci 405

 

到此基本的帧中继的配置已经完成,下面需要解决的就是水平分割的问题了.

水平分割默认为开,因此在R5上不会转发R2后面172.16.2.0这个子网的路由信息给R3.

解决这一问题就是在R5的serial1/0.1子接口上使用no ip split-horizon命令。例3-5 列出了完整的配置:

例3-5 图3-4中所有路由器的配置信息

hostname R5

!

interface Loopback1

 ip address 172.16.5.1 255.255.255.0

!

interface Serial1/0

 no ip address

 encapsulation frame-relay

 serial restart_delay 0

!        

interface Serial1/0.1 multipoint

 ip address 172.16.1.5 255.255.255.0

 frame-relay map ip 172.16.1.3 503 broadcast

 frame-relay map ip 172.16.1.2 502 broadcast

!

interface Serial1/0.2 point-to-point

 ip address 172.16.16.5 255.255.255.0

 frame-relay interface-dlci 504

-------------------------------------------------------

hostname R2

!

interface Loopback1

 ip address 172.16.2.1 255.255.255.0

!

interface Serial1/0

 ip address 172.16.1.2 255.255.255.0

 encapsulation frame-relay

 serial restart_delay 0

 frame-relay map ip 172.16.1.3 205 broadcast

 frame-relay map ip 172.16.1.5 205 broadcast

!

---------------------------------------------------------

hostname R3

!

interface Loopback1

 ip address 172.16.3.1 255.255.255.0

!

interface Serial1/0

 ip address 172.16.1.3 255.255.255.0

 encapsulation frame-relay

 serial restart_delay 0

 frame-relay map ip 172.16.1.5 305 broadcast

 frame-relay map ip 172.16.1.2 305 broadcast

!

-------------------------------------------------------

hostname R4

!

interface Loopback1

 ip address 172.16.4.1 255.255.255.0

!

interface Serial1/0

 ip address 172.16.16.4 255.255.255.0

 encapsulation frame-relay

 serial restart_delay 0

 frame-relay interface-dlci 405

!

在配置帧中继网络也可以在接口下加入bandwidth命令以便于route protocol准确的select routes。
="mso-bookmark: _Toc151817828">3.3 帧中继的big show” and “big D”

 

l       Show frame-relay pvc [ dlci | interface ]

l       Show frame-relay lmi

l       Show frame-relay map

l       Debug frame-relay lmi

3.3.1 show frame-realy pvc命令

 

可以显示router上的所有PVC,显示PVC的工作状态和前向显式拥塞通知/后向显式拥塞通知和数据包的DE位等信息。例3-6 显示了在R5上的PVC信息状态:

 

 

例3-5 show frame-relay pvc 命令的信息

 

 

R5#sho frame-relay pvc

 

 

 

 

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

 

 

 

 

              Active     Inactive      Deleted       Static

 

 

  Local          3            0            0            0

 

 

  Switched       0            0            0            0

 

 

  Unused         0            0            0            0

 

 

 

 

DLCI = 502, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1

 

 

 

 

  input pkts 30            output pkts 21           in bytes 3244     

 

 

  out bytes 1898           dropped pkts 0           in FECN pkts 0        

 

 

  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0        

 

 

  in DE pkts 0             out DE pkts 0        

 

 

  out bcast pkts 11        out bcast bytes 858      

 

 

  5 minute input rate 0 bits/sec, 0 packets/sec

 

 

  5 minute output rate 0 bits/sec, 0 packets/sec

 

 

  pvc create time 00:15:01, last time pvc status changed 00:15:01

 

 

         

 

 

DLCI = 503, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1

 

 

 

 

  input pkts 30            output pkts 21           in bytes 3272     

 

 

  out bytes 1898           dropped pkts 0           in FECN pkts 0        

 

 

  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0        

 

 

  in DE pkts 0             out DE pkts 0        

 

 

  out bcast pkts 11        out bcast bytes 858      

 

 

  5 minute input rate 0 bits/sec, 0 packets/sec

 

 

  5 minute output rate 0 bits/sec, 0 packets/sec

 

 

  pvc create time 00:15:05, last time pvc status changed 00:15:05

 

 

         

 

 

DLCI = 504, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.2

 

 

 

 

  input pkts 28            output pkts 27           in bytes 3132     

 

 

  out bytes 2426           dropped pkts 0           in FECN pkts 0        

 

 

  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0        

 

 

  in DE pkts 0             out DE pkts 0        

 

 

  out bcast pkts 27        out bcast bytes 2426     

 

 

  5 minute input rate 0 bits/sec, 0 packets/sec

 

 

  5 minute output rate 0 bits/sec, 0 packets/sec

 

 

  pvc create time 00:35:13, last time pvc status changed 00:34:03

 

 

R5#

 

 

字段“pvc create time”和“last time pvc status changed”这两个时间应该接近,如果不接近说明PVC工作状态不正常。 

 

 

根据PVC的三种状态可以判断出帧中继网络哪里有问题。

 

 

3.3.2 show frame-relay lmi命令

 

3-6 Show frame-relay lmi显示LMI不匹配的信息

R3(config-if)#do sho frame-relay lmi

 

 

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = CISCO

  Invalid Unnumbered info 0             Invalid Prot Disc 0

  Invalid dummy Call Ref 0              Invalid Msg Type 0

  Invalid Status Message 0              Invalid Lock Shift 0

  Invalid Information ID 0              Invalid Report IE Len 0

  Invalid Report Request 0              Invalid Keep IE Len 0

  Num Status Enq. Sent 405              Num Status msgs Rcvd 389

  Num Update Status Rcvd 0              Num Status Timeouts 16

 

 

R3(config-if)#do sho frame-relay lmi

 

 

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = CISCO

  Invalid Unnumbered info 0             Invalid Prot Disc 0

  Invalid dummy Call Ref 0              Invalid Msg Type 0

  Invalid Status Message 0              Invalid Lock Shift 0

  Invalid Information ID 0              Invalid Report IE Len 0

  Invalid Report Request 0              Invalid Keep IE Len 0

  Num Status Enq. Sent 426              Num Status msgs Rcvd 389

 

 

  Num Update Status Rcvd 0              Num Status Timeouts 37

 

 

注意例3-6中灰色部分的字段,Num Status Enq. Sent xxx是否随着Num Status msgs Rcvd yyy的数字在增长,如果只发不收,说明交换机or LMI匹配错误。

改正LMI类型后,使用clear counters清空接口的信息,再使用show frame-relay lmi命令查看,见例3-7所示恢复正常:

 

 

例3-7 显示LMI恢复正确后的信息

 

 

R3(config-if)#do sho frame-relay lmi

 

 

 

 

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI

 

 

  Invalid Unnumbered info 0             Invalid Prot Disc 0

 

 

  Invalid dummy Call Ref 0              Invalid Msg Type 0

 

 

  Invalid Status Message 0              Invalid Lock Shift 0

 

 

  Invalid Information ID 0              Invalid Report IE Len 0

 

 

  Invalid Report Request 0              Invalid Keep IE Len 0

 

 

  Num Status Enq. Sent 1                Num Status msgs Rcvd 1

 

 

  Num Update Status Rcvd 0              Num Status Timeouts 0

 

 

R3(config-if)#do sho frame-relay lmi

 

 

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI

  Invalid Unnumbered info 0             Invalid Prot Disc 0

  Invalid dummy Call Ref 0              Invalid Msg Type 0

  Invalid Status Message 0              Invalid Lock Shift 0

  Invalid Information ID 0              Invalid Report IE Len 0

  Invalid Report Request 0              Invalid Keep IE Len 0

  Num Status Enq. Sent 14               Num Status msgs Rcvd 14

 

 

  Num Update Status Rcvd 0              Num Status Timeouts 0

R3(config-if)#

3.3.3 show frame-relay map命令

 

显示本与loacl router相连的remote IP adderss DLCI,显示是动态还是静态获得的,可以验证frame-relay map命令是否执行和检查逆向ARP工作情况。例3-8 是显示的信息:

3-8 show frame-relay map命令输出结果

R3#sho frame-relay map

Serial1/0 (up): ip 172.16.1.5 dlci 305(0x131,0x4C10), static,

              broadcast,

              CISCO, status defined, active

Serial1/0 (up): ip 172.16.1.2 dlci 305(0x131,0x4C10), static,

              broadcast,

              CISCO, status defined, active

3.3.4 debug frame-relay lmi命令

 

该命令可以查看yourseqmyseq是否在递增,router收到一个序列号会将其加1并在下一次交换时以这个序列号返回,如果连续3次丢失LMI信息or keepalive,链路即复位。如果只有一个序列号改变了,说明可能是LMI不匹配造成。如果没有任何信息说明router and frame-relay switch 之间链路有连接问题。例3-9给出了正常工作时的信息:

3-9 debug frame-relay lmi显示信息

R3#debug frame-relay lmi

Frame Relay LMI debugging is on

Displaying all Frame Relay LMI data

R3#

01:25:04: Serial1/0(out): StEnq, myseq 78, yourseen 77, DTE up

 

 

01:25:04: datagramstart = 0x5800354, datagramsize = 14

01:25:04: FR encap = 0x00010308

01:25:04: 00 75 95 01 01 01 03 02 4E 4D

01:25:04:

01:25:04: Serial1/0(in): Status, myseq 78

01:25:04: RT IE 1, length 1, type 1

01:25:04: KA IE 3, length 2, yourseq 78, myseq 78

01:25:14: Serial1/0(out): StEnq, myseq 79, yourseen 78, DTE up

 

 

01:25:14: datagramstart = 0x5801ED4, datagramsize = 14

01:25:14: FR encap = 0x00010308

01:25:14: 00 75 95 01 01 00 03 02 4F 4E

01:25:14:

01:25:14: Serial1/0(in): Status, myseq 79

 

 

01:25:14: RT IE 1, length 1, type 0

01:25:14: KA IE 3, length 2, yourseq 79, myseq 79

01:25:14: PVC IE 0x7 , length 0x3 , dlci 305, status 0x2

01:25:24: Serial1/0(out): StEnq, myseq 80, yourseen 79, DTE up

01:25:24: datagramstart = 0x5AFB034, datagramsize = 14

01:25:24: FR encap = 0x00010308

01:25:24: 00 75 95 01 01 01 03 02 50 4F

01:25:24:

01:25:24: Serial1/0(in): Status, myseq 80

01:25:24: RT IE 1, length 1, type 1

01:25:24: KA IE 3, length 2, yourseq 80, myseq 80

3.3.5 其它帧中继配置命令

l        R3(config-if)#no frame-relay inverse-arp  禁止发送逆向ARPno arp frame-relay 命令一起使用可禁止PVC动态映射

l        R3(config-if)#no arp frame-relay   禁止ARP响应,和上一个命令结合使用

 

 

l        R3(config-if)#keepalive keepalive_interavl_in_seconds  修改keepalive时间,默认为10 seconds。链路两端必须一致。

 

 

l        Clear frame-relay-inarp  清除动态地址映射。

 

 

l        Frame-relay priority-dlci-group group_number high_dlci medium_dlci normal_dlci low_dlci  为不同类型的帧中继使用多个并行的DLCI

>3.5 帧中继流量整形

我们先看一个网络模型,图3-5这个模型中有几百个远端站点需要访问授权中心,假设在主站点到授权中心的链路出现问题,很快恢复了,在主站点到授权中心会出现许多TCP连接请求,出现大量数据,由于主站到授权中心的链路速率为64Kbit/s,产生拥塞,远端站点仍以T1的速率进行传输,并不知道主站到授权中心的链路只是64Kbit/sFrame-relay Traffic Shaping(帧中继流量整形)就是为解决这类问题。

3-5 帧中继网络模型

再看几个术语:

l        承诺速率计算间隔(Tc)  <125msTc=Bc/CIR。 

l        承诺信息速率(CIR  期望平均速率,和物理接口一致。 

l        承诺突发量(Bc  每个Tc时段时传送的数据量,通常为CIR1/8,单位bit/s

l        过量突发量(Be  试图传输超过CIR的那部分数据量,单位bit/s。实际由供应商决定。

l        最小承诺信息速率(MinCIR  信道拥挤时能够传送的最小数据量。

l        传输字节(Byte increment  =Bc/8,每个时段里传输的数据量。

l        前向显式拥塞通告(FECN)  当帧中继交换机察觉到发生拥塞,即向目的设备发送一个FECN数据包,指示有拥塞。

l        后向显式拥塞通告(BECN)  当帧中继交换机察觉到发生拥塞,即向源设备发送一个BECN数据包,指示降低发送数据包的速率。IOS 11.2 or later version supported BECN

l        可丢弃指示符(De)  网络发生拥塞时,有De编织物设置的数据包将被丢弃。

  

启动流量整形后,router在发送packet前会检查是否有可用的令牌桶or标志,事先定义令牌桶的容量,存有以一定速率放进去的令牌。任何时router发送的速率大小要和令牌桶一致。在数据送出接口之前都要通过为VC而建立的队列。

BECN响应模式:如果router收到BECN,则速率降低25%,在接下来每个Tc间隔后都再降低25%,起到降低到MinCIR为止。如果有16Tc间隔没有再收到BECN,速率则以每次(Be+Bc/16增加。配置帧中继流量整形步骤:

1步  允许FRTS  router(config-if)#frame-relay traffic-shaping

2步  创建映射类,router(config-if)#frame-relay class calss_name_l [ in | out ]

router(config)#map-class frame-relay class_name_l。前者可以多个VC使用同一个映射类。

3步  在映射类配置中设置选项:

n         Frame-relay adaptive-shaping [ becn | foresinght ]    使用BECN

n         Frame-relay cir [ in | out ]bit/s  将CIR设置为物理接口速率

n         Frame-relay bc [ in | out ]bit/s  合适的设置为远端设备的1/8CIR

n         Frame-relay be out bit/s    不应超过接口速率。

n         Frame-relay mincir [ in | out ]bit/s  设为和供应商提供的CIR值。

n         Frame-relay traffic-rate cir peak_speed    可选,不应超过接口速率,

4步  可选将队列应用于映射类,默认是FIFO

3.5.1 实例:帧中继流量整形的配置

3-6 为一个帧中继点对点网络

该实例中为防止R5发送大量数据到R2PVC,同时还要对传送到R3的流量整形,假设R5R3的接口速率为1.544Mbit/sR2则是64Kbit/sR5R2之间的PVCCIR供应商设定为32kbit/sR5R3之间的PVCCIR512Kbit/s

3-6

 

3-10 R5 FRTS:配置

R5(config)#int s1/0

R5(config-if)#frame-relay traffic-shaping    <-enable FRTS

R5(config-if)#exit

R5(config)#int s1/0.1

R5(config-subif)#frame

R5(config-subif)#frame-relay class 64kb       <-set map class

R5(config-subif)#exit

R5(config)#int s1/0.2

R5(config-subif)#frame-relay class t1

R5(config-subif)#

 

3-11配置映射类

 

R5(config)#map-class frame-relay 64kb   <-建立映射类

R5(config-map-class)#frame-relay adaptive-shaping becn   <-Eable BENC response

R5(config-map-class)#frame-relay cir 1544000      <-设置为物理端口速率

R5(config-map-class)#frame-relay bc 8000   <-设置为远端端口速率的1/8

R5(config-map-class)#frame-relay be 64000   <-Initail burst

R5(config-map-class)#frame-relay mincir 32000    <-Carrier enforced CIR

R5(config-map-class)#exit

R5(config)#map-class frame-relay t1

R5(config-map-class)#frame-relay adaptive-shaping becn

R5(config-map-class)#frame-relay cir 1544000

R5(config-map-class)#frame-relay bc 8000

R5(config-map-class)#frame-relay be 64000

R5(config-map-class)#frame-relay mincir 512000

R5(config-map-class)#

使用show traffic-shapeshow frame-relay pvc dlci_number命令验证FRTS配置,例3-12列出两条命令所显示的信息:

3-12 show traffic-shape and show frame-relay pvc 命令显示信息

R5#show traffic-shape

 

Interface   Se1/0.1

       Access Target    Byte   Sustain   Excess    Interval  Increment Adapt

VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active

503           1544000   9930   15440     64000     10        1930      BECN

502           1544000   9930   15440     64000     10        1930      BECN

 

Interface   Se1/0.2

       Access Target    Byte   Sustain   Excess    Interval  Increment Adapt

VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active

504           1544000   9930   15440     64000     10        1930      BECN

 

 

R5#show frame-relay pvc 502

 

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

 

DLCI = 502, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1

 

  input pkts 365           output pkts 205          in bytes 37862    

  out bytes 17038          dropped pkts 0           in FECN pkts 0        

  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0        

  in DE pkts 0             out DE pkts 0        

  out bcast pkts 188       out bcast bytes 15294    

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

  Shaping adapts to BECN

  pvc create time 04:11:05, last time pvc status changed 04:11:05

  cir 1544000   bc 15440     be 64000     byte limit 9930   interval 10 

  mincir 32000     byte increment 1930  Adaptive Shaping BECN

  pkts 13        bytes 1014      pkts delayed 0         bytes delayed 0       

  shaping inactive   

  traffic shaping drops 0

  Queueing strategy: fifo

  Output queue 0/40, 0 drop, 0 dequeued

R5#

实验4:配置帧中继网络

3.6.1         实验内容

  主要是练习点到多点和点到点的帧继基本配置命令。

l        安照图3-7 结构配置点到多点和点到点的帧中继网络。 

l        R5R2R3使用静态PVC映射。

l        R5R4之间使用动态PVC映射。

3.6.2         实验拓扑

  安照图3-7这个拓扑连接好设备。

3-7 实验拓扑

     3.6.3         所需设备

l        5router,其中一台配置为帧中继交换机。

l        背对背线缆4条。

3.6.4         实验步骤

1步  配置帧中继封装和子接口

     encapsulation frame-relay  [ cisco | ietf ]

          interface s1/0.1  [ point-to-point | multipoint ]

2步  配置LMI类型(本实验中采用自动识别)

     frame-relay lmi-type  [ ansi | cisco | q933i ]

3步  配置地址映射为动态or 静态

     frame-relay map protocol [ ip | dec | appletalk | xns | ipx | vines | clns | bridge | llc2 | dlsw ] next_hop_address [ broadcast ] [ ietf | cisco ]

     frame-relay interface-dlci dlci_number

  4步  关掉水平分割

在接口下no ip split-horizon

  5步  配置EIGRP,并关闭自动汇总。

       router eigrp as_number

network network_address subnet_mask

no auto-summary

6步  检查配置,检查路由。

3.6.5         完整配置

3-13 R5的配置

hostname R5

!

interface Loopback1

 ip address 172.16.5.1 255.255.255.0

!

interface Serial1/0

 no ip address

 encapsulation frame-relay

 no ip split-horizon

 no fair-queue

 serial restart_delay 0

!

interface Serial1/0.1 multipoint

 ip address 172.16.1.5 255.255.255.0

 frame-relay map ip 172.16.1.3 503 broadcast

 frame-relay map ip 172.16.1.2 502 broadcast

!

interface Serial1/0.2 multipoint

 ip address 172.16.16.5 255.255.255.0

 frame-relay interface-dlci 504

!

router eigrp 100

 network 172.16.1.0 0.0.0.255

 network 172.16.5.0 0.0.0.255

 network 172.16.16.0 0.0.0.255

 no auto-summary

 no eigrp log-neighbor-changes

!

 

3-14 R2的配置

hostname R2

!

interface Loopback1

 ip address 172.16.2.1 255.255.255.0

!

interface Serial1/0

 ip address 172.16.1.2 255.255.255.0

 encapsulation frame-relay

 serial restart_delay 0

 no arp frame-relay

 frame-relay map ip 172.16.1.3 205 broadcast

 frame-relay map ip 172.16.1.5 205 broadcast

 no frame-relay inverse-arp

!

router eigrp 100

 network 172.16.1.0 0.0.0.255

 network 172.16.2.0 0.0.0.255

 no auto-summary

!

 

 

3-15 R3的配置

hostname R3

!

interface Loopback1

 ip address 172.16.3.1 255.255.255.0

!

interface Serial1/0

 ip address 172.16.1.3 255.255.255.0

 encapsulation frame-relay

 serial restart_delay 0

 no arp frame-relay

 frame-relay map ip 172.16.1.2 205 broadcast

 frame-relay map ip 172.16.1.5 205 broadcast

 no frame-relay inverse-arp

!

router eigrp 100

 network 172.16.1.0 0.0.0.255

 network 172.16.3.0 0.0.0.255

 no auto-summary

!

 

3-16 R4的配置

hostname R4

interface Loopback1

 ip address 172.16.4.1 255.255.255.0

!

interface Serial1/0

 ip address 172.16.16.4 255.255.255.0

 encapsulation frame-relay

 serial restart_delay 0

 frame-relay interface-dlci 405

!

router eigrp 100

 network 172.16.4.0 0.0.0.255

network 172.16.16.0 0.0.0.255

 no auto-summary

 no eigrp log-neighbor-changes

!

3.6.6         验证配置

l        show ip route   显示路由信息,可以看到路由表是否正确。例3-16是在R5上执行该命令的结果。

l        show ip eigrp neighbors  验证EIGRP工作是否正常,是否建立了正确的邻居关系,例3-17

例3-17    R5上执行show ip route 的结果

R5#sho ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is not set

 

     172.16.0.0/24 is subnetted, 6 subnets

C       172.16.16.0 is directly connected, Serial1/0.2

D       172.16.4.0 [90/2297856] via 172.16.16.4, 00:11:18, Serial1/0.2

C       172.16.5.0 is directly connected, Loopback1

C       172.16.1.0 is directly connected, Serial1/0.1

D       172.16.2.0 [90/2297856] via 172.16.1.2, 00:11:18, Serial1/0.1

D       172.16.3.0 [90/2297856] via 172.16.1.3, 00:11:18, Serial1/0.1

R5#

 

例3-16          

R5#sho ip eigrp neighbors

IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq Type

                                            (sec)         (ms)       Cnt Num

2   172.16.16.4             Se1/0.2          137 00:13:42  256  1536  0  2  

1   172.16.1.3              Se1/0.1          172 00:14:08  297  1782  0  3  

0   172.16.1.2              Se1/0.1          164 00:15:55  215  1290  0  5  

R5#

3.7        实验5:配置帧中继流量整形及OSPF的配置

3.7.1         实验内容

 

l        此次实验的拓扑是一个全网状的帧中继网络

l        在网络中配置OSPF路由协议

l        布署帧中继流量整形

u       在R5路由器是配置流量整形,本地端口速率为1.544Mbit/s

u       R5R3PVCCIR32kbit/s

u       R3本地端口速率为64kbit/s,对此PVC进行流量整形。

3.7.2         实验拓扑

安照图3-8这个拓扑图进行实验

  图3-8,实验拓扑示意图

 

3.7.3         所需设备

l        4台路由器,一台配置为帧中继交换机

l        3条背对背线缆

l        PC一台

3.7.4         实验步骤

1步 安照帧中继的配置步骤R5帧中继封装

2步 配置地址静态映射

3步 配置路由协议

4步 启动FRTS

5步 为每条PVC配置一个映射类

6步 在子接口上应用帧中继映射类

在本实验中只在R5R3PVC上做流量整形。

3.7.5         完整配置

例3-16         R5的完整配置

hostname R5

!

interface Loopback1

 ip address 172.16.5.1 255.255.255.0

!

interface Serial1/0

 no ip address

 encapsulation frame-relay

 no fair-queue

 serial restart_delay 0

 frame-relay traffic-shaping

!

interface Serial1/0.1 multipoint

 ip address 172.16.1.5 255.255.255.248

 frame-relay class 64k

 frame-relay map ip 172.16.1.3 503 broadcast

 frame-relay map ip 172.16.1.2 502 broadcast

!

router ospf 501

 log-adjacency-changes

 network 172.16.1.0 0.0.0.7 area 0

 network 172.16.5.0 0.0.0.255 area 500

 neighbor 172.16.1.2 priority 1

 neighbor 172.16.1.3 priority 1

map-class frame-relay 64k

 frame-relay cir 1544000

 frame-relay bc 8000

 frame-relay be 64000

 frame-relay mincir 32000

 frame-relay adaptive-shaping becn

!

例3-17         R2的完整配置

hostname R2

!

interface Loopback1

 ip address 172.16.2.1 255.255.255.0

!

interface Serial1/0

 no ip address

 encapsulation frame-relay

 serial restart_delay 0

!

interface Serial1/0.1 multipoint

 ip address 172.16.1.2 255.255.255.248

 frame-relay map ip 172.16.1.3 203 broadcast

 frame-relay map ip 172.16.1.5 205 broadcast

!

router ospf 201

 log-adjacency-changes

 redistribute connected

 network 172.16.1.0 0.0.0.7 area 0

 network 172.16.2.0 0.0.0.255 area 200

 neighbor 172.16.1.5 priority 1

 neighbor 172.16.1.3 priority 1

!

 

例3-18         R3的完整配置

hostname R3

!

interface Loopback1

 ip address 172.16.3.1 255.255.255.0

!

interface Serial1/0

 no ip address

 encapsulation frame-relay

 serial restart_delay 0

!

interface Serial1/0.1 multipoint

 ip address 172.16.1.3 255.255.255.248

 frame-relay map ip 172.16.1.5 305 broadcast

 frame-relay map ip 172.16.1.2 302 broadcast

!

!

router ospf 301

 log-adjacency-changes

 redistribute connected

 network 172.16.1.0 0.0.0.7 area 0

 network 172.16.3.0 0.0.0.255 area 300

 neighbor 172.16.1.2 priority 1

 neighbor 172.16.1.5 priority 1

3.7.6         验证配置

在R5上使用show frame-relay pvc 503 验证流量整形的配置情况,见例3-20所示信息。

使用show ip route 进行验证OSPF是否正常工作。

例3-19         R5show frame-relay pvc 503的结果

R5#show frame-relay pvc 503

 

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

 

DLCI = 503, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1

 

  input pkts 28            output pkts 28           in bytes 2236     

  out bytes 2344           dropped pkts 0           in FECN pkts 0        

  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         

  in DE pkts 0             out DE pkts 0        

  out bcast pkts 0         out bcast bytes 0        

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

  Shaping adapts to BECN

  pvc create time 00:08:27, last time pvc status changed 00:07:18

  cir 1544000   bc 15440     be 64000     byte limit 9930   interval 10 

  mincir 32000     byte increment 1930  Adaptive Shaping BECN

  pkts 28        bytes 2344      pkts delayed 0         bytes delayed 0       

  shaping inactive   

  traffic shaping drops 0

  Queueing strategy: fifo

  Output queue 0/40, 0 drop, 0 dequeued

R5#

 

例3-20         show ip route 所得路由信息

R5#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is not set

 

     172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks

C       172.16.5.0/24 is directly connected, Loopback1

C       172.16.1.0/29 is directly connected, Serial1/0.1

O IA    172.16.3.1/32 [110/65] via 172.16.1.3, 00:06:27, Serial1/0.1

O IA    172.16.2.1/32 [110/65] via 172.16.1.2, 00:06:27, Serial1/0.1

R5#

 

例3-21         show ip ospf neighbor

R5#show ip ospf neighbor

 

Neighbor ID     Pri   State           Dead Time   Address         Interface

172.16.3.1        1   FULL/BDR        00:01:59    172.16.1.3      Serial1/0.1

172.16.2.1        1   FULL/DROTHER    00:01:41    172.16.1.2      Serial1/0.1

R5#


3.8         实验6:PPP over frame-relay的配置

3.8.1         实验内容

l        在Frame RelayPVC上建立端到端的PPP会话,注意:只能在PVC处于active状态时才能建立。能够在一条Frame-relay链路上的多个虚链路上存在多个PPP会话。(也就是说要PVC仅允许一个PPP会话)

l        一个PPP连接建立在一个虚拟访问接口上。

l        PPP over Frame Relay仅在IP上支持。

l        硬件压缩和一些队列不能应用于虚拟接口之上像weighted fair queueing, custom queueing, and priority queueing

l        默认,一个virtual template interface的封装类型是PPP,所以encapsulation PPP不会显示在你的配置中。

3.8.2         实验拓扑

在图3-9 PPP over frame-relay的拓扑示意图中,R5R6frame-relay上封装PPP协议。

3-9 PPP over frame-relay

 

3.8.3         所需设备

l       路由器3台,一台模拟帧中继交换机。

l       V.35线缆公头两条。

3.8.4         实验步骤

1步 在接口上配置帧中继封装。

2步 在子接口上配置Frame-relay 支持PPP

3步 配置虚拟接口,包括IP地址。

4步 配置PPP认证类型(可选),虚拟接口封装默认PPP。见例3-20 所示接口封装。

3-20 show interface virtual-template 1信息

R5#  sho int virtual-TEmplate 1

Virtual-Template1 is down, line protocol is down

  Hardware is Virtual Template interface

  Internet address is 172.16.11.5/24

  MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation PPP, loopback not set     <-默认封装PPP

  DTR is pulsed for 5 seconds on reset

  LCP Closed

  Closed: OSICP, BRIDGECP, TAGCP, IPCP, CCP, CDPCP, LLC2, IPXCP, NBFCP

          BACP, ATCP, IPV6CP

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 00:24:25

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue :0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

R5# sho run

R5#

3.8.5         完整配置

3-21 R5的完整配置

hostname R5

!

interface Serial1/1

 no ip address

 encapsulation frame-relay

 serial restart_delay 0

!

interface Serial1/1.1 point-to-point

 frame-relay interface-dlci 516 ppp Virtual-Template1

!

interface Virtual-Template1

 ip address 172.16.11.5 255.255.255.0

!

 

3-21 R6的完整配置

hostname R6

!

interface Serial1/0

 no ip address

 encapsulation frame-relay

 serial restart_delay 0

!

interface Serial1/0.1 point-to-point

 frame-relay interface-dlci 615 ppp Virtual-Template1

!

interface Virtual-Template1

 ip address 172.16.11.6 255.255.255.0

!

3.8.6         验证配置

使用show interface virtual-template 1显示接口状态。

使用show running-config 显示配置信息。

使用ping测试连通性。


posted on 2008-04-24 21:11 可冉 阅读(1013) 评论(0)  编辑 收藏 引用 所属分类: cisco

只有注册用户登录后才能发表评论。