posts - 8,  comments - 7,  trackbacks - 0
目的 两条电信不同网关线路,把内网的机器分成两部分,分别走一条,某一条断线时候会自动切换到另外一条,线路ok后,又切换回来。

首先添加双线IP地址,我这里分别是:
第一条        192.168.10.2/24 网关192.168.10.1   [公网]

第二条        192.168.20.2/24 网关 192.168.20.1   [公网]

内网 ROS IP地址为192.168.30.1             [内网]

[admin@lan] > ip ad pri                                                        
Flags: X - disabled, I - invalid, D - dynamic
#   ADDRESS        NETWORK     BROADCAST       INTERFACE
0   192.168.30.1/24    192.168.30.0    192.168.30.255        lan      
1   192.168.10.2/24    192.168.10.0    192.168.10.255         NO.1      
2   192.168.20.2/24    192.168.20.0    192.168.20.255         NO.2

添加好IP地址后,在ip firewall mangle添加路由标记。
注意其中的 斜体 部分是你内网分流的目标地址,红色字体为自己命的名字,后面只要对照上就可以了。

[admin@lan] > ip firewall mangle pri
Flags: X - disabled, I - invalid, D - dynamic
0   chain=prerouting src-address=192.168.30.2-192.168.30.127 action=mark-routing
     new-routing-mark=10 passthrough=yes

1   chain=prerouting src-address=192.168.30.128-192.168.30.254
     action=mark-routing new-routing-mark=20 passthrough=yes

做一个 ip伪装 / ip firewall nat add chain=srcnat action=masquerade

现在要在ip route 中添加两条网关信息
下面的routing-mark=20 就是上面所说的 自己命名 的对应值,
此处绿色的注释也可随便改,但是下面要对上
命令如下
[admin@lan] > /ip route add gateway=192.168.20.1 routing-mark=20 comment=link2
[admin@lan] > /ip route add gateway=192.168.10.1 routing-mark=10 comment=link1

到这里为止已经作完成了,可以上网

下面做个脚本监测 某条公网线路down掉后,自动切换到另外一条

创建四个脚本,如下 (这个是在图形界面下的 system script后点 + 号添加)
link1up
/ip route set link1 gateway=192.168.10.1
link1down
/ip route set link1 gateway=192.168.20.1
link2down
/ip route set link2 gateway=192.168.10.1
link2up
/ip route set link2 gateway=192.168.20.1

命令如下
/ system script
add name="link1down" source="/ip route set link1 gateway=192.168.20.1" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
add name="link1up" source="/ip route set link1 gateway=192.168.10.1" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
add name="link2up" source="/ip route set link2 gateway=192.168.20.1" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
add name="link2down" source="/ip route set link2 gateway=192.168.10.1" \

然后设置网络连接监测(此处的蓝色关系到脚本名字,上面蓝色处)
/ tool netwatch
add host=192.168.10.1 timeout=30ms interval=1s up-script=link1up \
    down-script=link1down comment="" disabled=no
add host=192.168.20.1 timeout=30ms interval=1s up-script=link2up \
    down-script=link2down comment="" disabled=no


 双线不同网关分流教程.rar


点击在新窗口查看全图
CTRL+鼠标滚轮放大或缩小 


点击在新窗口查看全图
CTRL+鼠标滚轮放大或缩小 


点击在新窗口查看全图
CTRL+鼠标滚轮放大或缩小 


 
posted on 2006-12-19 17:18 蝴蝶の风 阅读(1107) 评论(16)  编辑 收藏 引用

FeedBack:
# re: 双线不同网关分流教程
2007-06-26 15:32 | 维生素
哥们教教小弟请问我的是动态ADSL 俩条咋样分流!我想把1条分给192.168.1.100-192.168.1.150 还一条分给192.168.1.200-192.168.1.250请问咋设置啊!我现在只会拨一条ADSL还一条都还是闲置的!求求大!  回复  更多评论
  
# re: 双线不同网关分流教程
2010-07-09 22:49 | TerriSilva35
Make your life more easy take the <a href="http://bestfinance-blog.com/topics/personal-loans">personal loans</a> and everything you want.   回复  更多评论
  
# re: 双线不同网关分流教程
2010-07-21 11:20 | buy essay
Up-to-date students don't have complications with academic papers writing, because they buy essay papers and can focus on their own deals.   回复  更多评论
  
# re: 双线不同网关分流教程
2010-11-06 18:29 | essay writing services
Quantities of students work very hard, however, it does not mean that they can get high rates. Successful university students don't strive to work hard. They come to the essay writing company. It is important to do a right choice using not a long time.   回复  更多评论
  
# re: 双线不同网关分流教程
2013-05-28 09:09 | resume services
Make certain that you will possess authentic documents whenever you buy resume service on the Web.  回复  更多评论
  
只有注册用户登录后才能发表评论。
<2010年11月>
31123456
78910111213
14151617181920
21222324252627
2829301234
567891011

欢迎光临蝴蝶の风的个人博客

常用链接

留言簿(1)

随笔分类(2)

随笔档案(8)

最新随笔

搜索

  •  

积分与排名

  • 积分 - 5679
  • 排名 - 359

最新随笔

最新评论

阅读排行榜

评论排行榜