FC3安装MySQL 5

FC3自带的MySQL版本太低了, 想升级到MySQL 5,所以从管方网站下载了最新的RPM,心谂RPM应该省事了吧?结果在启动时总是说不能连接server。将所有新装的rpm都删除,从新安装FC3自带的版本也不行,重启再试,还是不行。

正感到绝望的时候,谂起apt-get。心想,用apt-get升级一下,可能就可以搞掂。OK,去!

先将现存的所有mysql*包删除,再用apt-get upgrade更新所有包,再用apt-get install mysql及mysql-server,再用apt-get remove mysql及mysql-server再从新安装MySQL 5的RPM,service mysql start,BINGO!nice to see you again.

posted on 2005-06-12 15:44 毒菇求Buy 阅读(270) 评论(1)  编辑 收藏 引用 所属分类: LinuxSQL

评论

# re: FC3安装MySQL 5 2005-06-13 12:32 alsan

my steps:
1. download mysql5* rpms (for linux x86)
2. uninstall mysql3 (rpm -e mysql*)
3. upgrade system (apt-get upgrade)
4. reinstall mysql3 from apt-get (apt-get install mysql*)
5. remove mysql3 (apt-get remove mysql*)
6. install mysql5 (rpm -ivh MySQL-5*)

note:
1. some steps are possibly not ncessary (2, 4)
2. step 3 could be the main point
3. welcome to post me a feedback if you can repeat these steps.
  回复  更多评论   

只有注册用户登录后才能发表评论。
<2005年6月>
2930311234
567891011
12131415161718
19202122232425
262728293012
3456789

导航

统计

常用链接

留言簿(7)

随笔分类(133)

随笔档案(111)

文章分类(65)

文章档案(53)

相册

收藏夹(30)

BLOG

Book store

Graphics Design

搜索

最新评论

阅读排行榜

评论排行榜