posts - 5,  comments - 0,  trackbacks - 0

Faulty Odometer


Time Limit : 1 second    Memory Limit : 32768 KB
Total Submit : 249    Accepted Submit : 141

Problem

You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 3 to the digit 5, always skipping over the digit 4. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15339 and the car travels one mile, odometer reading changes to 15350 (instead of 15340).

Input

Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 4.

Output

Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.

Sample input

13
15
2003
2005
239
250
1399
1500
999999
0

Sample output

13: 12
15: 13
2003: 1461
2005: 1462
239: 197
250: 198
1399: 1052
1500: 1053
999999: 531440

#include<cstdio>

#include<string>

#include<cmath>

using namespace std;

int main()

{

       char a[11], temp[11];

       int n, sum;

       int i, j, k;

       while(scanf("%s", a)!=EOF) {

              sum=0;

              n=strlen(a);

              if(n==1 && a[0]=='0') break;

              for(i=0; i<n; i++) {

                     temp[i]=a[i]-48;

                     //if(temp[i]>4) temp[i]--;                    

              }    

              for(i=0; i<n-1; i++) {

                     if(temp[i]<4)   sum=sum+temp[i]*(int)pow(double(9), double(n-i-1));

                     else sum=sum+(temp[i]-1)*(int)pow(double(9), double(n-i-1));

              }

              if(temp[n-1]>4) sum=sum+temp[n-1]-1;

              else sum=sum+temp[n-1];

                    

             

              printf("%s: %d\n", a, sum);

       }

       return 0;

}

posted on 2007-03-14 15:04 forever 阅读(328) 评论(1)  编辑 收藏 引用
只有注册用户登录后才能发表评论。